Ankündigung

Einklappen
Keine Ankündigung bisher.

Verschiebung der Einstellung alter PHP-Versionen & Info zur neuen Webserverplattform

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • wecotec
    antwortet
    Zitat von Benutzername Beitrag anzeigen
    Also da muss ich Dir wiedersprechen. Das ist kein elitäres Gebrösel sondern richtig!
    In der Theorie gebe ich dir 100% Recht. Die Praxis sieht (wenigstens für Reseller) anders aus.

    Wenn man nur einen Shop oder eine Webseite betreibt ist es auch kein Problem diese immer auf den neusten Stand zu halten....vor allem wenn man selber bestimmt welche Software eingesetzt wird. Dies ist aber bei Resellern oft nicht der Fall.

    Einen Kommentar schreiben:


  • Benutzername
    antwortet
    Zitat von wsp Beitrag anzeigen
    Auf das elitäre Gebrösel kann verzichtet werden. Es gibt hier auch Leute, die das nicht zwingend als "Hobby" betreiben und die versuchen die Webseite als "Nebenbetrieb" zum täglichen Business zu nutzen - und da macht es keinen Sinn, die Webseite alle 2-3 Jahre komplett zu erneuern - absolut unnötig ständig auf dem neuesten Trend zu sein (Ich rede hier nicht von mir - sondern von MEINEN Kunden!)!
    Also da muss ich Dir wiedersprechen. Das ist kein elitäres Gebrösel sondern richtig!
    Gerade wenn die Website (wie bei Shops) zum Geld verdienen genutzt wird, dann ist sie ein Arbeitsmittel. Und diese aktuell zu halten gehört nun einmal zum Business dazu! Das Auto muss ja auch regelmäßig zum Tüv und bei Mängeln repariert (Update) oder getauscht (Upgrade) werden. Bei Websites ist eben dass "Problem", dass die Intervalle sehr kurz sind. D.h. es muss von Anfang an die Updatefähigkeit ein wichtiges Kriterium sein. Ein irgendwo gekauftes billiges Theme, dass dann bis zum xten Level angepasst wird ist eben nicht updatefähig.
    D.h. wenn z.B. der Shop / die Website nur als Nebenbetrieb zur Website genutzt wird, dann rate doch DEINEN Kunden zur Nutzung eines Baukastens oder einer Mietlösung. Diese sind in der Regel sehr stabil bzw. werden zentral an neue Bedingungen angepasst. Die Zeiten des "Wir basteln uns da mal eine Website" sind außerhalb des Privatbereichs eben vorbei. Und auch wir Dienstleister können da an vielen Stellen noch einiges an Qualität drauf legen. Klar, steigen da die Preise, aber es kommt einem besseren und sicheren Internet zu gute...

    Einen Kommentar schreiben:


  • wsp
    antwortet
    Zitat von Schakal Beitrag anzeigen
    Wer bis Heute noch Webseiten mit PHP 5.x nutzen möchte/muss hat in den letzten 3 Jahren geschlafen.
    Auf das elitäre Gebrösel kann verzichtet werden. Es gibt hier auch Leute, die das nicht zwingend als "Hobby" betreiben und die versuchen die Webseite als "Nebenbetrieb" zum täglichen Business zu nutzen - und da macht es keinen Sinn, die Webseite alle 2-3 Jahre komplett zu erneuern - absolut unnötig ständig auf dem neuesten Trend zu sein (Ich rede hier nicht von mir - sondern von MEINEN Kunden!)! Wer was anders behauptet wird auch zuviel in Google-Ads investieren, weil ers sich marketingmässig hypnotisieren hat lassen...
    Ich denke, die kleineren Reseller hier wissen, was ich meine! Bei der sicheren Quota-Lösung etc. kann es gar nicht passieren, dass über den Kunden hinaus ein Risiko enstehen kann... ansonsten sind auch die neueren Versionen nicht sicherer!
    Zuletzt geändert von wsp; 06.01.2021, 11:06.

    Einen Kommentar schreiben:


  • wecotec
    antwortet
    Zitat von Benutzername Beitrag anzeigen
    Es läuft doch eine Sicherheitsoffensive! Zukünftig heisst das eben, dass df keine alten PHP Versionen mehr patcht, d.h. sobald seitens der PHP Community das EOL Datum erreicht ist, wird eben die Version abgestellt. OK, auf einigen dF Systemen läuft auf Shell Ebene noch PHP 4
    Wenn dF diese Widersprüche mal auflösen würde käme (wenigstens von mir) mehr Akzeptanz für diese "Sicherheitsoffensive". Davon mal abgesehen ist diese "Offensive" unglaubwürdig solange Dinge wie 2FA nicht implementiert sind.

    Zitat von Benutzername Beitrag anzeigen
    aber das wird vermutlich wieder ein Ressourcenproblem sein. Vielleicht sind auch die Gewimne zu knapp, um an der Stelle noch zu investieren.
    Exakt das könnte man sich auch für das RP2-System denken.....

    Zitat von Benutzername Beitrag anzeigen
    Die neue Plattform soll es ja nun richten.
    Leider 2 Jahre zu spät....aber das ist den Übernahmen in der Zeit geschuldet, die entgegen anders lautender Aussagen nie Synergieeffekte für uns Kunden gebracht haben. Wir Kunden haben da eher unter Reibungsverlusten gelitten. Aktuell sehe ich auch keine sichtbaren Synergien, eher das Gegenteil ist der Fall.

    Einen Kommentar schreiben:


  • Schakal
    antwortet
    Zitat von zero81 Beitrag anzeigen
    So ganz verstehe ich nicht, warum hier so strikt vorgegangen wird, zumal ich einige andere Anbieter kenne, die teilweise sogar noch PHP 5 anbieten.
    Es gibt auch genügend Webhoster, die schon vor langer Zeit sich von PHP 5.x und PHP 7.0 und 7.1 verabschiedet haben. Ersters sollte eigentlich heutzutage keine Diskussion mehr geben. Wer bis Heute noch Webseiten mit PHP 5.x nutzen möchte/muss hat in den letzten 3 Jahren geschlafen.


    Zitat von zero81 Beitrag anzeigen
    Ich weiß, trotzdem kann ich es nicht nachvollziehen. Anfangs war ja nur von PHP5 die Rede, was für mich noch nachvollziehbar ist, aber dann gleich mit PHP 7 nachzuziehen war schon seltsam.
    Es ist auf einer gewissen Art schon nachvollziebar. Grundlage dafür ist PHP:Supported Versions. Damit ist auch nachvollziebar warum PHP 5.x, 7.0, 7.1 und 7.2 auch auf der alten Plattform verschwindet. Letzteres läuft in wenigen Tagen aus dem offziellen Support Cyle aus.

    Zitat von zero81 Beitrag anzeigen
    IWär jedenfalls interessant zu wissen, wie lange PHP 7.2 auf den alten Tarifen noch läuft, oder ob hier gar eine Zwangstarifumstellung angedacht ist,
    Dazu gibt es wie so oft die Standardaussage. Aktuell gibt es dazu keine Pläne. Aber sobald Details vorliegen werden diese rechtzeitig publiziert. Ich persönliche vermute ja, dass PHP 7.2 dort nicht ad-hoc verschwinden wird. Ich gehe aktuell von einer Zwangsmigration aus. :-(

    Einen Kommentar schreiben:


  • Benutzername
    antwortet
    Zitat von zero81 Beitrag anzeigen

    Ich weiß, trotzdem kann ich es nicht nachvollziehen. Anfangs war ja nur von PHP5 die Rede, was für mich noch nachvollziehbar ist, aber dann gleich mit PHP 7 nachzuziehen war schon seltsam. Wär jedenfalls interessant zu wissen, wie lange PHP 7.2 auf den alten Tarifen noch läuft, oder ob hier gar eine Zwangstarifumstellung angedacht ist,
    Es läuft doch eine Sicherheitsoffensive! Zukünftig heisst das eben, dass df keine alten PHP Versionen mehr patcht, d.h. sobald seitens der PHP Community das EOL Datum erreicht ist, wird eben die Version abgestellt. OK, auf einigen dF Systemen läuft auf Shell Ebene noch PHP 4, aber das wird vermutlich wieder ein Ressourcenproblem sein. Vielleicht sind auch die Gewimne zu knapp, um an der Stelle noch zu investieren. Die neue Plattform soll es ja nun richten. Fun Fakt: auf den neuen bei dF weiterverkauften Godaddy Angeboten kannst Du Dir vermutlich problemlos noch ein altes PHP installieren... Die Sicherheitsoffensive kann da aufgrund der Offenheit des Angebots nicht durchgreifen. Hoffen wir nur, dass diese Systeme extrem gut vom restlichen dF System abgeschottet sind, damit Sicherheitsprobleme in alten PHP Versionen oder anderen, von den Kundinnen und Kunden installierten Anwendungen nicht auf den Rest durchgreifen. Das ist ja die Befürchtung bei PHP < 7.2, dass es bei einem Sicherheitsproblem bei einem Kunden dann auf das restliche System durchgreift.

    Einen Kommentar schreiben:


  • zero81
    antwortet
    Zitat von wsp Beitrag anzeigen

    Gute Frage - aber rund 2 Jahre zu spät... df) hat Grundsatz-Diskussionen diesbezüglich längst hinter sich.... es laufen ja bereits die Umsetzungen (sprich Löschungen bis und mit 7.1)!
    Ich weiß, trotzdem kann ich es nicht nachvollziehen. Anfangs war ja nur von PHP5 die Rede, was für mich noch nachvollziehbar ist, aber dann gleich mit PHP 7 nachzuziehen war schon seltsam. Wär jedenfalls interessant zu wissen, wie lange PHP 7.2 auf den alten Tarifen noch läuft, oder ob hier gar eine Zwangstarifumstellung angedacht ist,

    Einen Kommentar schreiben:


  • wsp
    antwortet
    Zitat von zero81 Beitrag anzeigen
    So ganz verstehe ich nicht, warum hier so strikt vorgegangen wird, zumal ich einige andere Anbieter kenne, die teilweise sogar noch PHP 5 anbieten.
    Gute Frage - aber rund 2 Jahre zu spät... df) hat Grundsatz-Diskussionen diesbezüglich längst hinter sich.... es laufen ja bereits die Umsetzungen (sprich Löschungen bis und mit 7.1)!

    Einen Kommentar schreiben:


  • zero81
    antwortet
    So ganz verstehe ich nicht, warum hier so strikt vorgegangen wird, zumal ich einige andere Anbieter kenne, die teilweise sogar noch PHP 5 anbieten.

    Einen Kommentar schreiben:


  • alderim
    antwortet
    Auch Shopware 5.5.8 kann nach dem 15.1. dadurch nicht mehr in einen neuen Tarif umgezogen werden.

    der online Support meinte zudem php 7.2. wird am 15.1. komplett abgestellt.

    Einen Kommentar schreiben:


  • zero81
    antwortet
    Hm, dann müssen wir unseren Magento-Kunden so oder so wegtransferieren, da wir auf einen neuen Tarif wechseln wollen.
    Das hatte ich nicht im Blick, dass PHP 7.2 bei den neuen Tarifen auch nicht mehr möglich ist, zumindest in Kürze.

    Einen Kommentar schreiben:


  • Schakal
    antwortet
    Wird php 7.2. jetzt zum 15.1. bei „alten„ Accounts abgestellt?
    Nein, wer lesen kann ist klar im Vorteil.

    Hier nochmals die Aussage von dF vom 10.11.2020, 23:43:
    In den neuen 64-Bit-Tarifen steht PHP 7.2 bis 15.01.2021 zur Verfügung:
    Wir hoffen, dass bis Sommer 2021 die alten Tarife erhalten bleiben und damit verbunden auch PHP 7.2. Toi toi toi...

    Einen Kommentar schreiben:


  • zero81
    antwortet
    Zitat von alderim Beitrag anzeigen
    Wird php 7.2. jetzt zum 15.1. bei „alten„ Accounts abgestellt?

    danke für Info
    Ich hoffe mal nicht. Wir haben zwar nur mehr einen Kunden mit einem Magento-Shop, der auf PHP 7.2 läuft. Die Domain wird aber im Auftrag auch nicht rot markiert und im Hinweis steht nichts von der Umstellung von PHP 7.2.
    Wenn PHP 7.2 tatsächlich so bald umgestellt wird, wäre das recht unangenehm, da der Kunde den Shop vor einem Jahr wegen der PHP5-Umstellung aktualisieren ließ und 7.2 die max. Version bei Magento 1.x ist, soweit ich weiß. Dann bliebe nichts anderes übrig, als zu einem anderen Anbieter umzuziehen inkl. dem Kunden beibringen, dass die ganze Aktualisierung letztlich das Problem nur ein Jahr verzögert hat.

    Einen Kommentar schreiben:


  • alderim
    antwortet
    Wird php 7.2. jetzt zum 15.1. bei „alten„ Accounts abgestellt?

    danke für Info

    Einen Kommentar schreiben:

  • Nils Dornblut
    Kundenservice

  • Nils Dornblut
    antwortet
    Zitat von Martin11 Beitrag anzeigen

    Bitte wirken Sie darauf hin, dass eine mögliche Abschaltung in diesem speziellen Fall frühzeitig an die Kunden kommuniziert wird. Frühzeitig wäre in meinen Augen mind. zwei Monate, besser drei. Ist das nach Ihrer Erfahrung realistisch?
    Garantieren kann ich das nicht, aber es denke ich sehr passend weitergeben. Bin da optimistisch, dass wir im Sinne aller dort gute Lösungen finden werden. Klar, Stillstand wird nicht die Divise sein und - wie auch hier schon - werden wir es sicher nicht allen recht machen können. Aber wie gesagt, wir versuchen es!

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:

Lädt...
X