Ankündigung

Einklappen
Keine Ankündigung bisher.

In welchen Tarifen kann man PHP 8.x mit JIT-Compiler nutzen?

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    In welchen Tarifen kann man PHP 8.x mit JIT-Compiler nutzen?

    Hallo!

    Ich habe aktuell ein Webhosting Premium 64 Bit, leider hat mir die Technik mitgeteilt, dass es dort nicht möglich ist, den neuen PHP JIT-Compiler zu nutzen, der mit PHP 8 gekommen ist. Meine Frage wäre daher, in welchen Tarifen ich dies tun kann. Muss ich direkt auf einen Managed oder gar Dedicated Server umsteigen?

    Grüße
    Zuletzt geändert von Cangooou; 05.05.2022, 15:44.

    #2
    Zitat von Cangooou Beitrag anzeigen
    Hallo!

    Ich habe aktuell ein Webhosting Premium 64 Bit, leider hat mir die Technik mitgeteilt, dass es dort nicht möglich ist, den neuen PHP JIT-Compiler zu nutzen, der mit PHP 8 gekommen ist. Meine Frage wäre daher, in welchen Tarifen ich dies tun kann. Muss ich direkt auf einen Managed oder gar Dedicated Server umsteigen?

    Grüße
    In welchem Zusammenhang wollen Sie JIT nuten und wie ist die Ticket-ID? Mein Stand bisher war, dass wir es zwar im default deaktivieren, sie es aber per .user.ini eine Aktivierung vornehmen können:

    https://forum.df.eu/forum/allgemein/...=8120#post8120

    Mit freundlichen Grüßen

    Nils Dornblut
    Blog - Facebook - Twitter
    Communitybetreiber: domainfactory GmbH
    Impressum / Pflichtangaben

    Kommentar


      #3
      Danke für Ihre Antwort! Die Ticket-Nummer ist die #9813844. Dort wurde mir gesagt, dass es in sämtlichen 64-Bit-ManagedHosting-Tarifen nicht möglich sei, JIT zu nutzen, da "wir innerhalb des neuen Systemes auf file_cache setzen, für die Verwendung des jit jedoch "memory" benötigt würde".
      Ich habe (auch) die in Ihrem Link angegebene .user.ini mit:

      opcache.jit = 'on'

      ausprobiert, das Ergebnis ist, das im angehängten Bild der phpinfo JIT immer auf "disabled" bleibt (oben im Block), obwohl weiter unten dann steht:

      opcache.jit: tracing


      Da das nicht ganz eindeutig ist, hatte ich einen weiteren Test ausgeführt, der anzeigen soll, ob JIT läuft:

      var_dump(opcache_get_status());

      Dort erhalte ich dann auch durchweg bei DF nur:
      array(3) { ["opcache_enabled"]=> bool(false) ["file_cache"]=> string(37) "/temp/xxx/uxxxx/example.com" ["file_cache_only"]=> bool(true) }

      während bei einem lokalen Testsystem bei aktiviertem JIT dann kommt:
      array(9) { ["opcache_enabled"]=> bool(true) ["cache_full"]=> bool(false) .... ["jit"]=> array(7) { ["enabled"]=> bool(true) ["on"]=> bool(true) ["kind"]=> int(5) ["opt_level"]=> int(4) ["opt_flags"]=> int(6) ["buffer_size"]=> int(0) ["buffer_free"]=> int(0) } }

      Auch merke ich keinen Performance-Unterschied, ob ich nun opcache.jit = 'on' in der .user.ini habe oder nicht. Bei uns lokal betriebene Testserver zeigen da schon einen messbaren Unterschied, weshalb wir das auch wirklich gerne nutzen würden, ich glaube, ich muss niemandem mehr sagen, wie wichtig eine schnelle Webseite ist.

      Es scheint auch egal zu sein, ob man PHP 8.0 oder 8.1 nutzt - komisch dass es bei Ihnen funktioniert hatte.

      Ich selbst betreibe und betreue verschiedene ManagedHosting 64 Tarife (von ManagedHosting 64 Premium bis zu ManagedServer 64 Pro), aber bei denen scheint es dann überall nicht zu gehen.
      Angehängte Dateien
      Zuletzt geändert von Cangooou; 11.05.2022, 14:01.

      Kommentar


        #4
        Laut diesem Tutorial muss opcache zwingend aktiviert sein damit JIT funktionieren kann.
        https://stitcher.io/blog/php-8-jit-setup

        Versuche das mal zusätzlich in deiner .user.ini zu aktivieren.
        MfG,
        masterframe

        Kommentar


          #5
          Danke für Deine Antwort.

          opcache.enable=1
          opcache.jit=1255
          (auch mit und ohne opcache.jit_buffer_size=100M)

          habe ich in der .user.ini versucht, leider ohne Erfolg. Warmum phpinfo sagt: opcache.enabled: on, aber var_dump(opcache_get_status()); sagt: array(3) { ["opcache_enabled"]=> bool(false), weiß ich leider auch nicht.

          Zuletzt geändert von Cangooou; 11.05.2022, 17:29.

          Kommentar


            #6
            Dann noch den nginx Cache deaktivieren.
            MfG,
            masterframe

            Kommentar


              #7
              Ist/war bei mir eigentlich immer deaktiviert, mit:

              Header set Cache-Control: s-maxage=0

              in der htaccess.

              Kommentar

              Lädt...
              X