Ankündigung

Einklappen
Keine Ankündigung bisher.

Sprachenwechsel bei Joomla - Was tun?

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Nils Dornblut
    antwortet
    Zitat von zero81 Beitrag anzeigen
    Ok, dann ist es seltsam. Ich müsste die Einstellungen im Backend sehen, um eventuell ein Problem zu erkennen.
    Hier ggf. eine Kontaktaufnahme via PN angeraten und eine gemeinsame Remotesitzung.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • zero81
    antwortet
    Ok, dann ist es seltsam. Ich müsste die Einstellungen im Backend sehen, um eventuell ein Problem zu erkennen.

    Einen Kommentar schreiben:


  • TinMZG
    antwortet
    zero81 Ja, ich habe alles so gemacht, wie es für Mehrsprachen-Seiten üblich ist. Hat ja hier auch bisher geklappt, und auf anderen Mehrsprachen-Seiten gibt es ebenfalls keine Probleme.

    Einen Kommentar schreiben:


  • zero81
    antwortet
    Hast du einen eigenes Menü mit einem Menüpunkt Startseite und Sprache "Alle" bzw. für jede Sprache ein eigenes Menü + jeweilige Sprache zugewiesen + Startseite, die auch als solche deklariert ist?

    Einen Kommentar schreiben:


  • Kailash
    antwortet
    Tja, bei mir hier das gleiche Verhalten wie in meinem gestrigen Beitrag geschildert.

    Einen Kommentar schreiben:


  • TinMZG
    antwortet
    zero81 masterframe . Danke für's nachschauen. Komisch - bei mir funktioniert es in Firefox, Edge und auf dem Handy. Warum es hier jetzt geht und bei euch nicht - Fragen über Fragen...

    Einen Kommentar schreiben:


  • masterframe
    antwortet
    Zitat von zero81 Beitrag anzeigen

    Also ich hab es jetzt nochmal probiert, bei mir funktioniert der Sprachwechsel (Firefox) weder in JP noch in EN > 404.
    Muss ich leider bestätigen.
    Es funktioniert nicht.

    Einen Kommentar schreiben:


  • zero81
    antwortet
    Zitat von TinMZG Beitrag anzeigen
    Vielen Dank, Kailash Enigma Pascal zero81 . Ihr habt mir schon ein wenig weitergeholfen und der Hinweis mit dem Sitzungscookie ist gut. Das witzige ist - gerade logge ich neu ein und will weiter testen und siehe da, plötzlich geht wieder alles. Ich kann mir das nicht erklären, hoffe aber, was immer es war, dass die Seite nun funktional bleibt.

    Es wäre falsch, das Thema als "solved" zu setzen, da die Ursache ja im unklaren geblieben ist. Zumindest jetzt aber gilt - Problem existiert jetzt nicht (mehr).

    Gruß,
    TinMZG
    Also ich hab es jetzt nochmal probiert, bei mir funktioniert der Sprachwechsel (Firefox) weder in JP noch in EN > 404.

    Einen Kommentar schreiben:


  • TinMZG
    antwortet
    Vielen Dank, Kailash Enigma Pascal zero81 . Ihr habt mir schon ein wenig weitergeholfen und der Hinweis mit dem Sitzungscookie ist gut. Das witzige ist - gerade logge ich neu ein und will weiter testen und siehe da, plötzlich geht wieder alles. Ich kann mir das nicht erklären, hoffe aber, was immer es war, dass die Seite nun funktional bleibt.

    Es wäre falsch, das Thema als "solved" zu setzen, da die Ursache ja im unklaren geblieben ist. Zumindest jetzt aber gilt - Problem existiert jetzt nicht (mehr).

    Gruß,
    TinMZG

    Einen Kommentar schreiben:


  • zero81
    antwortet
    Sieht, wie schon jemand geschrieben hat, nach einem Konfigurationsfehler im Joomla aus, zumindest mit SSL hat es sicher nichts zu tun.
    Zuletzt geändert von zero81; 09.01.2020, 17:34.

    Einen Kommentar schreiben:


  • Pascal
    antwortet
    Hi,

    hast du mal den "Mehrsprachenstatus" überprüft? Den kannst du unten links in der grauen Leiste aufrufen, nachdem du das Admin-Modul veröffentlichst hast. Damit du es in der Modulübersicht siehst, vorher in der Select Box "Administrator" auswählen.

    Sind die Inhaltssprachen korrekt konfiguriert?
    Sprach Tags: de-DE, en-GB, ja-JP
    Sprachlürzel: de, en, jp

    Gibt es einen globalen Home/Standard Menüpunkt und welche für die jeweiligen Sprachen?

    Ich gehe davon aus, dass es ein Konfigurationsfehler ist und kein Bug.

    Gruß
    Pascal

    Einen Kommentar schreiben:


  • Enigma
    antwortet
    Es muss an dem Sitzungs-Cookie liegen. Lösche ich das vor dem Aufruf einer anderen Sprache, funktioniert es. Ich vermeide aber wo möglich den Kontakt mit Joomla, daher kann ich Dir leider nicht sagen, was Du umstellen musst. Gab's letztens ein Update des Switcher-Plugins? Evtl. ist es ja ein Bug.

    Gruß
    Jan

    Einen Kommentar schreiben:


  • Kailash
    antwortet
    Hi,
    also wenn ich die japanische Seite das erste mal aufrufe wird sie mir angezeigt, will ich dann aber auf englisch wechseln kommt ein 404. Versuche ich dann wieder auf die japanische zu kommen, ebenfalls nun ein 404.
    Starte ich den Browser (Chrome) neu, geht das Spiel genau wie oben beschrieben wieder von vorne los.
    Kann dir da aber leider auch nicht weiterhelfen, aber vielleicht hilft dir das obige Beschriebene etwas weiter.

    Einen Kommentar schreiben:


  • TinMZG
    hat ein Thema erstellt Sprachenwechsel bei Joomla - Was tun?.

    Sprachenwechsel bei Joomla - Was tun?

    Hallo Community,

    ich komme gerade bei Joomla mit dem Sprachenwechsel nicht weiter. Ansich funktionierte der Wechsel bisher problemlos zwischen Deutsch, Englisch und Japanisch, Webseite https://kodeja.de

    Die DE-Seite (Standard) ohne das "DE" Kürzel funktioniert problemlos. Wenn ich auf https://kodeja.de/en oder https://kodeja.de/jp wechseln will, erscheint ein 404 Fehler. Wenn ich für die Standardsprache über das Switcher Plugin die Abkürzung beifüge, also https://kodeja.de/de ist ebenfalls 404 Fehler.

    Ich kann nicht mehr nachvollziehen, ab wann das Problem aufgetaucht ist (Installation von neuen Modulen/Plugins, SSL-Zerfitikatverlängerung, ...) und kenne mich nicht ausreichend aus, um bei aktivierten Errorlogs in Joomla etwas Sinnvolles für die 404 Seiten angezeigt zu bekommen.

    Wer hat eine Idee?


    Grüße,
    TinMZG
Lädt...
X