Ankündigung

Einklappen
Keine Ankündigung bisher.

Fehler in Software mit PHP-Version 7.73

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Nils Dornblut
    antwortet
    Hallo Silvia,

    Updates sind immer eine gute Idee

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • SilviaD.
    antwortet

    Ich habe mir dafür noch nicht die Zeit genommen und bin inzwischen auf die glorreiche Idee geschubst worden, einfach mal nach einem Update der alten Software-Version zu schauen.
    Siehe da, das Programm wird doch noch weiterentwickelt. Mit dem Update sollte dann auch der Fehler behoben sein.
    Trotzdem Danke der Nachfrage.

    Grüße
    Silvia

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von SilviaD. Beitrag anzeigen
    Danke!
    Ein Eingriff in den Programmcode ist für mich immer gefühlt eine "OP am offenen Herzen".
    Das probiere ich morgen aus, wenn ich ausgeschlafen bin.
    Es sind aber schon mal hoffnungsvolle Aussichten, dass das Problem lösbar scheint.
    Hat die OP denn funktioniert?

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • SilviaD.
    antwortet
    Danke!
    Ein Eingriff in den Programmcode ist für mich immer gefühlt eine "OP am offenen Herzen".
    Das probiere ich morgen aus, wenn ich ausgeschlafen bin.
    Es sind aber schon mal hoffnungsvolle Aussichten, dass das Problem lösbar scheint.

    Grüße
    Silvia

    Einen Kommentar schreiben:


  • masterframe
    antwortet
    Diese Möglichkeit sieht so aus als ob es funktionieren könnte:
    https://stackoverflow.com/a/54767431

    Ich habe das aber nicht selbst getestet.

    Fürs Erste würde es auch reichen das error_reporting zu deaktivieren. Aber das ist keine echte „Lösung“.

    Einen Kommentar schreiben:


  • SilviaD.
    hat ein Thema erstellt Fehler in Software mit PHP-Version 7.73.

    Fehler in Software mit PHP-Version 7.73

    Hallo,

    ich nutze für meine Familienforschung das Programm Webtrees, http://webtrees.net/ in der Version 1.7.9.
    Es gibt seit einiger Zeit eine neue Version 2.x, die aber komplett anders aufgebaut ist und bei der für mich wichtige Funktionen fehlen.
    Böse Zungen behaupten, die neue Version würde "beim Kunden reifen".

    Allerdings hat die Version 1.7.9. Probleme mit der aktuellen PHP-Version 7.73. Zumindest eine Programmfunktion ist praktisch nicht mehr verfügbar.
    Es gibt im Programm die Möglichkeit eine Startperson festzulegen (üblicherweise man selbst) und dann zu jeder beliebigen Person das Verwandtschaftssverhältnis ausrechnen und anzeigen zu lassen. Das Ergebnis ist dann"Großvater" oder "Onkel 2. Grades" usw.

    Stelle ich im Kundenmenü die PHP-Version auf eine ältere Version, funktioniert das, nicht aber bei 7.73, dann erscheint diese Fehlermeldung:

    /kunden/xxxxx_xxxxx/webtrees1/includes/session.php:193 /kunden/xxxxxx_xxxxx/webtrees1/vendor/fisharebest/algorithm/src/Dijkstra.php:84 The each() function is deprecated. This message will be suppressed on further calls #0 unknown:unknown ErrorException("/kunden/xxxxxx_xxxxx/webtrees1/vendor/fisharebest/algorithm/src/Dijkstra.php:84 The each() function is deprecated. This message will be suppressed on further calls") #1 /vendor/fisharebest/algorithm/src/Dijkstra.php:84 each([array]) #2 /vendor/fisharebest/algorithm/src/Dijkstra.php:130 extractPaths('I33518') #3 /app/Controller/RelationshipController.php:67 shortestPaths('I39160', 'I33518') #4 /relationship.php:56 calculateRelationships([Individual [email protected]], [Individual [email protected]], 0, false)
    Gibt es eine Möglichkeit die Version 7.73 zu nutzen und gleichzeitig dem Programm "vorzugaukeln", dass eine ältere Version läuft?
    Oder hat jemand eine Idee, wie man sonst den Fehler beheben kann?
    Der Entwickler verweist auf die Nutzung der neuen Version.

    Danke und Grüße
    Silvia
Lädt...
X