Ankündigung

Einklappen
Keine Ankündigung bisher.

Probleme mit htaccess-Zugangsschutz nach Umstellung auf ManagedHosting 64

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Nils Dornblut
    antwortet
    Hallo sake23,

    vielen Dank für die Ergänzung!

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • sake23
    antwortet
    Bei mir hat es in ähnlicher Situation (Sicherung des Wordpress-Zugangs /wp-login.php mit .htaccess) auch nicht funktioniert, obwohl gem. den Beiträgen hier alles richtig implementiert war.
    Der Support hat dann geholfen:

    Auf dem neuen System sind eigene Fehlerseiten leider nicht möglich, daher führt die Umleitung: "ErrorDocument 401 /errordocs/401.html" zum entsprechenden Fehler. Wir haben die Zeile nun auskommentiert.

    Der Support hat noch
    Code:
    <Files wp-login.php>
    in
    Code:
    <FilesMatch wp-login.php>
    geändert, und
    Code:
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    auskommentiert.



    Diese Fehler haben dann offenbar auch die Sicherung zum "Abstürzen" gebracht (Umleitungsfehler).
    Zuletzt geändert von sake23; 08.03.2021, 17:21.

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von Diarmiud Beitrag anzeigen
    Zum anderen musste noch ein Fehler auf dem Server behoben werden. Der wurde nicht näher benannt, aber ich denke, dieser wird nun auf allen Servern behoben sein.
    Nur um es vollständig zu machen, hier noch eine Rückmeldung! Der Fehler lag hierbei in der Zeile:

    „require user“

    Damit erwartet die .htaccess als Benutzerangabe „user“ welchen es so nicht gab. Korrekt ist:

    „require valid-user“

    Damit werden dann die Benutzer aus der .htpasswd verwendet.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von Diarmiud Beitrag anzeigen
    Gerne. Die Ticket-ID lautete: #8911681
    Super, ich frage da zur Sicherheit intern noch nach. Anpassung FAQ ist eingeleitet.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • Diarmiud
    antwortet
    Gerne. Die Ticket-ID lautete: #8911681

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Hallo Diarmiud,

    danke für die "Selbstlösung" hier im Thema und Ihre Rückmeldungen. Um die FAQ kümmern wir uns gerne noch entsprechend. Können Sie noch die Ticket-ID als Referenz nennen, wo Sie mit uns kommuniziert haben?

    Vielen Dank und beste Grüße

    Nils Dornblut

    Einen Kommentar schreiben:


  • Diarmiud
    antwortet
    Das Problem wäre gelöst.

    Zum einen muss nach der Umstellung
    AuthPGAuthoritative Off
    aus der .htaccess auskommentiert werden.

    Zum anderen musste noch ein Fehler auf dem Server behoben werden. Der wurde nicht näher benannt, aber ich denke, dieser wird nun auf allen Servern behoben sein.

    Ich denke die FAQ unter
    https://www.df.eu/de/support/df-faq/...-faq/htaccess/
    werden noch entsprechend angepasst.

    Einen Kommentar schreiben:


  • Diarmiud
    antwortet
    Ich habe gerade gelesen, dass der Support bat, derartige Probleme direkt per Mail zu melden. Das habe ich eben getan. Ich poste aber hier gerne die Lösung.

    Einen Kommentar schreiben:


  • Probleme mit htaccess-Zugangsschutz nach Umstellung auf ManagedHosting 64

    Heute wurde bei uns auf ManageHosting 64 umgestellt. Es scheint alles sehr gut zu funktionieren, nur der Zugangsschutz bei einem Verzeichnis löst seitdem 500 Internal Server Error aus.

    Ich habe schon den Pfad im Account kontrolliert, den User testhalber geändert und den Browsercache geleert. Das Ergebnis bleibt leider das gleiche. Auch mit anderen Browsern.

    Lösche ich die .htaccess-Datei läuft alles bestens. Aber ich brauche natürlich den Verzeichnisschutz.

    Unsere .htaccess:
    # .htaccess-Datei fuer das Verzeichnis /kommando
    AuthType Basic
    AuthName "TopSecret-Gazetten-Bereich"
    AuthUserFile /kunden/xxx/webseiten/xxx/kommando/.htusers
    AuthPGAuthoritative Off
    require user

    Die zugehörige .htuser:
    # .htuser-Datei
    usernameassword

    Woran mag es liegen?

    Viele Grüße
    Peter
Lädt...
X