Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem bei Moodle Installation - 3.10+

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • frawi
    antwortet
    Welche Version für den OPCache hast du denn verwendet?

    Probier mal die .htaccess nur um
    Code:
    RequestHeader unset Range
    zu ergänzen und dann eine .php.ini anlegen mit:
    Code:
    opcache.enable=0
    Bei der .htaccess Variante für opcache bin ich mir nicht sicher, ich verwende die .php.ini

    Viel Erfolg beim testen
    Frank

    Einen Kommentar schreiben:


  • paulhoertnagl
    antwortet
    Hallo frawi!
    Danke für die rasche Antwort. Habe beide Anpassungen vorgenommen und die .htaccess ins Verzeichnis xxx/moodle hochgeladen. Allerdings kommt nun eine Fehlermeldung (Internal Server Error).
    Hast du eine Idee?
    Danke!

    Einen Kommentar schreiben:


  • frawi
    antwortet
    Hallo paulhoertnagl,

    wie oben und in der von dir eingefügten .htaccess beschrieben in dieser folgendes eintragen:

    Code:
    RequestHeader unset Range
    In der .user.ini dann:

    Code:
    opcache.enable=0
    oder alternativ müsste das in der .htaccess so aussehen (habe ich aber selbst nicht ausprobiert):

    Code:
    php_flag opcache.enable Off
    Herzlichen Gruß
    Frank
    Zuletzt geändert von frawi; 04.04.2022, 17:06.

    Einen Kommentar schreiben:


  • paulhoertnagl
    antwortet
    Hallo!
    Ich stehe gerade beim selben Problem bei der Installation von Moodle. Wie muss den der Inhalt der .htaccess aussehen? Reicht der Eintrag dieser einzelnen Zeile oder muss mehr eingetragen werden?

    Ich habe eine Standard-.htaccess von Moodle hergenommen mit folgendem Inhalt:

    Code:
    # .htacess für Moodle Installation
    DirectoryIndex index.php index.html index.htm
    php_value memory_limit 40M (adjust to your version of Moodle)
    php_flag magic_quotes_gpc 1
    php_flag magic_quotes_runtime 0
    php_flag file_uploads 1
    php_flag session.auto_start 0
    php_flag session.bug_compat_warn 0
    
    # Eintrag df für Moodle-Installation RequestHeader unset Range
    
    # If you have Apache version 2 installed, add these lines:
    <IfDefine APACHE2>
    AcceptPathInfo on
    </IfDefine>
    # Upload File Size
    LimitRequestBody 0
    php_value upload_max_filesize 200M
    php_value post_max_size 200M
    Funktioniert aber leider nicht.
    Danke für die Hilfe!

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von martin.prechtl Beitrag anzeigen
    Danke, die Technik hat bereits geholfen!

    Bitte ergänzen Sie einmal die Zeile:

    Code:
    RequestHeader unset Range
    in der .htaccess Ihrer Moodle-Installation. Der Punkt opcache.enable.0 in der .user.ini ist an sich nur notwendig wenn Probleme bei einem Update der Moodle-Instanz auftreten.
    Super, danke für die Rückmeldung. Es scheint hier ja größeres Interesse zu geben und wir möchten daher gerne Antworten auf solche Fragen auch im Forum haben.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • martin.prechtl
    antwortet
    Danke, die Technik hat bereits geholfen!

    Bitte ergänzen Sie einmal die Zeile:

    RequestHeader unset Range

    in der .htaccess Ihrer Moodle-Installation. Der Punkt opcache.enable.0 in der .user.ini ist an sich nur notwendig wenn Probleme bei einem Update der Moodle-Instanz auftreten.

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Hallo Herr Prechtl,

    ob der Tipp in jedem Fall etwas bringt, können wir nicht verifizieren. Bitte wenden Sie sich gerne an die Technik über das Kundenmenü, dann können wir uns das ansehen und schauen, wie man das beheben kann.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • martin.prechtl
    antwortet
    Hallo Herr Dornblut,
    vielen Dank für die Unterstützung, aber leider hat der entsprechende Eintrag in der .user.ini keine Änderung gebracht. Anstatt eines Moodle-Hinweises, dass man keinen Zutritt zum jeweiligen Kurs hat, kommt eine Fehlerseite. Leider funktioniert auch eine aktivierte Selbsteinschreibung nicht mehr.

    Mit freundlichen Grüßen
    Martin Prechtl

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von martin.prechtl Beitrag anzeigen
    Hallo,
    unsere Moodle-Installation ist kürzlich von einem 32-bit-Server auf einen ManagedHosting 64 umgezogen worden. Seitdem erscheint innerhalb des Moodle-System die Fehlerseite "ERR_UNEXPECTED_PROXY_AUTH" wenn ein User eine unautorisierte Seite anwählt. Ich würde gerne obigen Vorschlag "opcache.enable=0" in die .user.ini eintragen. Aber wie und wo kann ich die .user.ini entsprechend editieren?
    Sie können ein paar wenige Werte im Kundenmenü anpassen und erhalten dann im Root-Verzeichnis der Domain eine solche Datei. Nicht in der Tabelle aufgeführte Einstellungen können Sie direkt in der user.ini auf Ihrem Webspace vornehmen. Auch könne Sie beliebige weitere solche Dateien in den jeweiligen Verzeichnissen von Skripten ablegen. Sie vererbt sich auch in Unterverzeichnisse, wenn es dort keine .unser.ini gibt. Weitere Infos hierzu finden Sie in unser FAQ:

    https://www.df.eu/de/support/df-faq/...rachen/#c24182

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von frawi Beitrag anzeigen
    Bin mir nicht ganz sicher, ob das ergänzt worden ist, oder ob ich es vorher tatsächlich übersehen habe. Geholfen hat:
    opcache.enable=0 in der .user.ini
    Danke für den Hinweis, dies bitte gerne probieren. Ein .user.ini kann in jedem Verzeichnis mit dem Inhalt angelegt werden. Diese vererbt sich auch in Unterverzeichnisse, muss also nur im Hauptverzeichnis existieren.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von Boellerjoe Beitrag anzeigen
    Guten Morgen Herr Dornblut,

    vielen Dank, ich habe Anfrage 9031608 geöffnet.
    Verzweifele so langsam an diesem Problem, habe gestern 5-6 mal alles gelöscht und versucht erneut zu installieren, allerdings ohne Erfolg.
    Vielleicht können die Kollegen anhand von Logfiles einen Hinweis geben, wo der Hund begraben liegt.
    Mit Hilfe der Technik konnte das damals gelöst werden. In dem Fall musste das Memory Limit extrem erhöht werden (2 GB) und es gab noch ein Punkt, der durch die Technik gelöst wurde. Also falls es Probleme bei der Installation gibt, wenden Sie sich bitte über das Kundenmenü an die Technik, wobei ich bitte die nächsten Einträge hier im Thread noch zu lesen.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • martin.prechtl
    antwortet
    Hallo,
    unsere Moodle-Installation ist kürzlich von einem 32-bit-Server auf einen ManagedHosting 64 umgezogen worden. Seitdem erscheint innerhalb des Moodle-System die Fehlerseite "ERR_UNEXPECTED_PROXY_AUTH" wenn ein User eine unautorisierte Seite anwählt. Ich würde gerne obigen Vorschlag "opcache.enable=0" in die .user.ini eintragen. Aber wie und wo kann ich die .user.ini entsprechend editieren?

    Grüße Martin

    Einen Kommentar schreiben:


  • frawi
    antwortet
    Hallo zusammen,

    ich hatte das gleiche Problem (bis eben :-) ). Bin schon lange bei df und dann auf ManagedHosting 64 umgestiegen. Die vorhandenen Moodle Installation lief auch weiter.

    Jedoch gab es Probleme beim Update und eine Neuinstallation war nicht möglich, gleiches Problem wie hier beschrieben: https://moodle.org/mod/forum/discuss.php?d=395478

    Auch ein langer und sehr guter Kontakt mit dem Support von df (Danke für die Bemühungen und Tests) brachte bisher keine Lösung. Auch ich hatte den nginx im Verdacht, da es der einzige wesentliche Unterschied zu vorher zu sein schien.

    Heute bin ich dann (ist ja Wochenende ;-) ) über diesen Eintrag gestolpert: https://www.df.eu/de/support/df-faq/...ctory/?#c24136

    Bin mir nicht ganz sicher, ob das ergänzt worden ist, oder ob ich es vorher tatsächlich übersehen habe. Geholfen hat:
    opcache.enable=0 in der .user.ini

    Ich hoffe, das hilft weiter - ich war jedenfalls schon am verzweifeln und wollte den Provider wechseln - ist nun also nicht nötig.

    Herzlichen Gruß
    Frank Wittemeier

    Einen Kommentar schreiben:


  • Boellerjoe
    antwortet
    Guten Morgen Herr Dornblut,

    vielen Dank, ich habe Anfrage 9031608 geöffnet.
    Verzweifele so langsam an diesem Problem, habe gestern 5-6 mal alles gelöscht und versucht erneut zu installieren, allerdings ohne Erfolg.
    Vielleicht können die Kollegen anhand von Logfiles einen Hinweis geben, wo der Hund begraben liegt.

    Mit freundlichem Gruß
    Julian Stolzenburg

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Hallo Julian,

    bitte wenden Sie sich einmal über das Kundenmenü an unsere Technik. Wir schauen uns das dann gerne an was machbar ist. Gerne hier die Ticket ID hinterlassen, wenn Sie die Anfrage gestellt haben.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:

Lädt...
X