Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem bei Moodle Installation - 3.10+

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Nils Dornblut
    antwortet
    Zitat von martin.prechtl Beitrag anzeigen
    Danke, die Technik hat bereits geholfen!

    Bitte ergänzen Sie einmal die Zeile:

    Code:
    RequestHeader unset Range
    in der .htaccess Ihrer Moodle-Installation. Der Punkt opcache.enable.0 in der .user.ini ist an sich nur notwendig wenn Probleme bei einem Update der Moodle-Instanz auftreten.
    Super, danke für die Rückmeldung. Es scheint hier ja größeres Interesse zu geben und wir möchten daher gerne Antworten auf solche Fragen auch im Forum haben.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • martin.prechtl
    antwortet
    Danke, die Technik hat bereits geholfen!

    Bitte ergänzen Sie einmal die Zeile:

    RequestHeader unset Range

    in der .htaccess Ihrer Moodle-Installation. Der Punkt opcache.enable.0 in der .user.ini ist an sich nur notwendig wenn Probleme bei einem Update der Moodle-Instanz auftreten.

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Hallo Herr Prechtl,

    ob der Tipp in jedem Fall etwas bringt, können wir nicht verifizieren. Bitte wenden Sie sich gerne an die Technik über das Kundenmenü, dann können wir uns das ansehen und schauen, wie man das beheben kann.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • martin.prechtl
    antwortet
    Hallo Herr Dornblut,
    vielen Dank für die Unterstützung, aber leider hat der entsprechende Eintrag in der .user.ini keine Änderung gebracht. Anstatt eines Moodle-Hinweises, dass man keinen Zutritt zum jeweiligen Kurs hat, kommt eine Fehlerseite. Leider funktioniert auch eine aktivierte Selbsteinschreibung nicht mehr.

    Mit freundlichen Grüßen
    Martin Prechtl

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von martin.prechtl Beitrag anzeigen
    Hallo,
    unsere Moodle-Installation ist kürzlich von einem 32-bit-Server auf einen ManagedHosting 64 umgezogen worden. Seitdem erscheint innerhalb des Moodle-System die Fehlerseite "ERR_UNEXPECTED_PROXY_AUTH" wenn ein User eine unautorisierte Seite anwählt. Ich würde gerne obigen Vorschlag "opcache.enable=0" in die .user.ini eintragen. Aber wie und wo kann ich die .user.ini entsprechend editieren?
    Sie können ein paar wenige Werte im Kundenmenü anpassen und erhalten dann im Root-Verzeichnis der Domain eine solche Datei. Nicht in der Tabelle aufgeführte Einstellungen können Sie direkt in der user.ini auf Ihrem Webspace vornehmen. Auch könne Sie beliebige weitere solche Dateien in den jeweiligen Verzeichnissen von Skripten ablegen. Sie vererbt sich auch in Unterverzeichnisse, wenn es dort keine .unser.ini gibt. Weitere Infos hierzu finden Sie in unser FAQ:

    https://www.df.eu/de/support/df-faq/...rachen/#c24182

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von frawi Beitrag anzeigen
    Bin mir nicht ganz sicher, ob das ergänzt worden ist, oder ob ich es vorher tatsächlich übersehen habe. Geholfen hat:
    opcache.enable=0 in der .user.ini
    Danke für den Hinweis, dies bitte gerne probieren. Ein .user.ini kann in jedem Verzeichnis mit dem Inhalt angelegt werden. Diese vererbt sich auch in Unterverzeichnisse, muss also nur im Hauptverzeichnis existieren.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Zitat von Boellerjoe Beitrag anzeigen
    Guten Morgen Herr Dornblut,

    vielen Dank, ich habe Anfrage 9031608 geöffnet.
    Verzweifele so langsam an diesem Problem, habe gestern 5-6 mal alles gelöscht und versucht erneut zu installieren, allerdings ohne Erfolg.
    Vielleicht können die Kollegen anhand von Logfiles einen Hinweis geben, wo der Hund begraben liegt.
    Mit Hilfe der Technik konnte das damals gelöst werden. In dem Fall musste das Memory Limit extrem erhöht werden (2 GB) und es gab noch ein Punkt, der durch die Technik gelöst wurde. Also falls es Probleme bei der Installation gibt, wenden Sie sich bitte über das Kundenmenü an die Technik, wobei ich bitte die nächsten Einträge hier im Thread noch zu lesen.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • martin.prechtl
    antwortet
    Hallo,
    unsere Moodle-Installation ist kürzlich von einem 32-bit-Server auf einen ManagedHosting 64 umgezogen worden. Seitdem erscheint innerhalb des Moodle-System die Fehlerseite "ERR_UNEXPECTED_PROXY_AUTH" wenn ein User eine unautorisierte Seite anwählt. Ich würde gerne obigen Vorschlag "opcache.enable=0" in die .user.ini eintragen. Aber wie und wo kann ich die .user.ini entsprechend editieren?

    Grüße Martin

    Einen Kommentar schreiben:


  • frawi
    antwortet
    Hallo zusammen,

    ich hatte das gleiche Problem (bis eben :-) ). Bin schon lange bei df und dann auf ManagedHosting 64 umgestiegen. Die vorhandenen Moodle Installation lief auch weiter.

    Jedoch gab es Probleme beim Update und eine Neuinstallation war nicht möglich, gleiches Problem wie hier beschrieben: https://moodle.org/mod/forum/discuss.php?d=395478

    Auch ein langer und sehr guter Kontakt mit dem Support von df (Danke für die Bemühungen und Tests) brachte bisher keine Lösung. Auch ich hatte den nginx im Verdacht, da es der einzige wesentliche Unterschied zu vorher zu sein schien.

    Heute bin ich dann (ist ja Wochenende ;-) ) über diesen Eintrag gestolpert: https://www.df.eu/de/support/df-faq/...ctory/?#c24136

    Bin mir nicht ganz sicher, ob das ergänzt worden ist, oder ob ich es vorher tatsächlich übersehen habe. Geholfen hat:
    opcache.enable=0 in der .user.ini

    Ich hoffe, das hilft weiter - ich war jedenfalls schon am verzweifeln und wollte den Provider wechseln - ist nun also nicht nötig.

    Herzlichen Gruß
    Frank Wittemeier

    Einen Kommentar schreiben:


  • Boellerjoe
    antwortet
    Guten Morgen Herr Dornblut,

    vielen Dank, ich habe Anfrage 9031608 geöffnet.
    Verzweifele so langsam an diesem Problem, habe gestern 5-6 mal alles gelöscht und versucht erneut zu installieren, allerdings ohne Erfolg.
    Vielleicht können die Kollegen anhand von Logfiles einen Hinweis geben, wo der Hund begraben liegt.

    Mit freundlichem Gruß
    Julian Stolzenburg

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Hallo Julian,

    bitte wenden Sie sich einmal über das Kundenmenü an unsere Technik. Wir schauen uns das dann gerne an was machbar ist. Gerne hier die Ticket ID hinterlassen, wenn Sie die Anfrage gestellt haben.

    Mit freundlichen Grüßen

    Nils Dornblut

    Einen Kommentar schreiben:


  • Boellerjoe
    hat ein Thema erstellt Problem bei Moodle Installation - 3.10+.

    Problem bei Moodle Installation - 3.10+

    Hallo zusammen,

    ich habe Probleme, Moodle auf dem "ManagedHosting 64 Medium" zu installieren.
    Die Installation bricht nach Eingabe der Datenbankinformationen mit folgender Meldung ab:

    ------------------------------------------------------------
    Es sieht so aus, als ob die Webseite unter http://moodle.xxxx.de/user/editadvanced.php?id=2 Probleme hat oder sie wurde möglicherweise dauerhaft zu einer neuen Webadresse verschoben.

    ERR_UNEXPECTED_PROXY_AUTH
    ------------------------------------------------------------

    Durch einige Recherche bin ich nun darauf gestoßen, dass wohl die ngix-Konfiguration angepasst werden müsste, was aufgrund des Managed-Hostings aber schwer werden dürfte?!
    Oder gibt es eine Möglichkeit?
    Speziell geht es um folgende Konfiguration:

    location ~ [^/]\.php(/|$) {
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_index index.php;
    fastcgi_pass 127.0.0.1:9000 (or your php-fpm socket);
    include fastcgi_params;
    fastcgi_param PATH_INFO $fastcgi_path_info;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    }

    Oder liegt vielleicht ein anderes Problem vor?
    Ich habe die Rechte der angelegten Ordner bereits geprüft und auch den Cache mehrmals gelöscht, die Installation stoppt aber immer wieder an gleicher Stelle.

    Danke & Gruß
    Julian

Lädt...
X