Ankündigung

Einklappen
Keine Ankündigung bisher.

Datenbankänderung & Aktualisierung

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Datenbankänderung & Aktualisierung

    Hallo zusammen,

    ich habe eine Seite online an der ich gerade bastel.

    Es werden eine Daten aus einer Datenbank abgerufen und funktioniert auch soweit.
    Wenn ich jetzt unter PHPmyAdmin von Hand Daten in einer Tabelle ändere und dann auf der Seite aktualisiere, wird die Seite nicht
    mit den neuen Daten angezeigt.
    Cache usw. ist natürlich gelöscht und ich habe die Seite vollständig neu geladen.

    Was mache ich falsch, oder wie erreiche eine vollständige Aktualisierung?

    Vielen Dank und Grüße
    Toeb

    #2
    Erfolgt die Aktualisierung auch nicht nach 10-15 Minuten? Die neuen Tarifen haben diesen Cache, wo offenbar die Aktualisierung länger dauern kann, lässt sich aber deaktivieren: https://www.df.eu/de/support/df-faq/...domainfactory/

    Kommentar


      #3
      Danke für die Antwort. Leider kann ich nicht viel damit anfangen:
      Alle 64-Bit-Tarife haben OPcache per Default aktiviert.

      Dem Apache-Webserver ist eine nginx als Proxy und Caching-System vorgeschaltet. Dies bedeutet eine bessere Performance Ihrer Webseite. Bis Änderungen an Ihrer Webseite sichtbar werden, kann wegen des Cachings etwas mehr Zeit vergehen als in unseren 32-Bit-Tarifen.

      Unter Umständen, z.B. während Arbeiten an Ihrer Webseite, kann es erforderlich sein, das Caching zu deaktivieren. Gehen Sie hierzu bitte wie folgt vor:

      Zum Deaktivieren des OPcache ergänzen oder ändern Sie in der .user.ini folgende Zeile:
      opcache.enable=0
      Um das Caching der nginx zu deaktivieren, ergänzen Sie die .htaccess-Datei um folgende Zeile:
      Header always set Cache-Control: s-maxage=0
      Ich finde keine user.ini Datei und eine htaccess Datei finde ich ebenfalls nicht. Wie stelle ich das an?
      PS: es ist immer noch nicht aktualisiert.

      Kommentar


        #4
        .htaccess Datei muss man erstellen und ins Root-Verzeichnis laden, user.ini auch, glaub ich.
        Aber hier wirds wohl nicht am Cache liegen, wenn sich das über so lange Zeit nicht aktualisiert, da weiß ich leider auch keinen Rat.

        Kommentar


          #5
          Dateien die mit einem "." (Punkt) beginnen, werden bei Systemen wie Unix/Linux als "versteckte Dateien" behandelt. Eventuell musst du in deinem FTP-Programm noch einstellen, dass es dir auch die ".htaccess" auf deinem Server anzeigt, nachdem du diese erstellt hast.

          Kommentar

          Lädt...
          X