Ankündigung

Einklappen
Keine Ankündigung bisher.

Webserver/Client Version bei MariaDB

Einklappen
Dieses Thema ist beantwortet.
X
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Webserver/Client Version bei MariaDB

    Hallo zusammen,
    nachdem ich vor einigen Tagen auf ManagedHosting 64 umstellen lies fehlen mir Informationen zu den Datenbanken die in der normalen 32Bit noch vorhanden waren.

    Das nun MariaDB-10.4 vorhanden ist und ich zwischen Maria und MySQL wählen kann ist ja super.
    Leider sehe ich aber nix mehr zu den weiteren Versionen wie Client-Version oder Webserver-Version

    Früher stand das alles nach dem Login auf der rechten Seite.
    Klicken Sie bitte auf die Grafik für eine vergrößerte Ansicht

Name: Früher.png
Ansichten: 207
Größe: 42,6 KB
ID: 10953

    Nun steht da nur noch:
    Klicken Sie bitte auf die Grafik für eine vergrößerte Ansicht

Name: Neu.png
Ansichten: 136
Größe: 14,2 KB
ID: 10954
    Mir fehlen also aussagen zur:
    Webserver bzw. Datenbank-Client Version.

    Kann mir vielleicht jemand von euch sagen wo ich diese Infos finde oder welche Datenbank-Client Version nun aktuell ist?

    Danke


  • Als beste Antwort auf Ursprungsfrage markiert von Nils Dornblut am 28.02.2022, 22:54. Der Beitrag wird direkt hier zusätzlich eingeblendet.

    Zitat von ITMedia Beitrag anzeigen
    Mir fehlen also aussagen zur:
    Webserver bzw. Datenbank-Client Version.

    Kann mir vielleicht jemand von euch sagen wo ich diese Infos finde oder welche Datenbank-Client Version nun aktuell ist?
    Die mysqlnd Version können Sie in der phpinfo() einsehen.

    Beispiel für PHP 8.0.12:
    Klicken Sie bitte auf die Grafik für eine vergrößerte Ansicht

Name: 2022-02-28_23h50_37.png
Ansichten: 84
Größe: 86,8 KB
ID: 11028

    Bei 7.2 ist die älter:

    mysqlnd 5.0.12-dev - 20150407

    bei 7.3 auch

    mysqlnd 5.0.12-dev - 20150407

    bei 7.4

    mysqlnd 7.4.25

    bei 8.0

    mysqlnd 8.0.12

    bei 8.1

    mysqlnd 8.1.0

    Das entspricht immer der entsprechenden Version im PHP-src:

    https://github.com/php/php-src/blob/...qlnd/mysqlnd.h

    Mit freundlichen Grüßen

    Nils Dornblut

    Kommentar


      #2
      Hallo ITMedia,

      für welchen Zweck brauchen Sie die Informationen genau? Gerne erfrage ich das dann bei der Technik.

      Mit freundlichen Grüßen

      Nils Dornblut
      Blog - Facebook - Twitter
      Communitybetreiber: domainfactory GmbH
      Impressum / Pflichtangaben

      Kommentar


        #3
        Das sollte man auch auf der Konsole sehen können.
        Code:
        apache2 -v
        MfG,
        masterframe

        Kommentar


          #4
          Zitat von masterframe Beitrag anzeigen
          Das sollte man auch auf der Konsole sehen können.
          Code:
          apache2 -v
          Genau "Sollte man"
          ist aber nicht mehr da.

          Kommentar


            #5
            Zitat von Nils Dornblut Beitrag anzeigen
            Hallo ITMedia,

            für welchen Zweck brauchen Sie die Informationen genau? Gerne erfrage ich das dann bei der Technik.

            Mit freundlichen Grüßen

            Nils Dornblut
            Hallo,
            das muss erst erfragt werden? Warum wird das denn jetzt weggeblendet.

            Ich benötige das für ein PHP-Script das bisher auf der alten 32-er Plattform nicht lief weil Datenbank auf der 32er bei PHP 7.2 nur MariaDB 10.1 / MySQL 5.0 - somit die Webserver (Cient-Version) einfach nur alt war.

            Als Client benötige ich aber neuere Versionen ab: : libmysql - mysqlnd 7.4.27 bei einer Admin Version von mind. 5.1.1


            Kommentar


              #6
              Zitat von ITMedia Beitrag anzeigen
              das muss erst erfragt werden? Warum wird das denn jetzt weggeblendet.
              Weil Domainfactory leider die Strategie fährt "Security through obscurity"
              Markus
              ---
              https://www.facebook.com/markus.weber.180410

              Kommentar


                #7
                Zitat von wecotec Beitrag anzeigen

                Weil Domainfactory leider die Strategie fährt "Security through obscurity"
                Das ist falsch. Jeder PEN-Test wird Ihnen als Finding ausgeben, wenn Sie solche Informationen direkt zugänglich machen und eben nicht ausblenden.

                Mit freundlichen Grüßen

                Nils Dornblut
                Blog - Facebook - Twitter
                Communitybetreiber: domainfactory GmbH
                Impressum / Pflichtangaben

                Kommentar


                  #8
                  Zitat von ITMedia Beitrag anzeigen
                  das muss erst erfragt werden? Warum wird das denn jetzt weggeblendet.
                  Ich habe dazu vorab etwas geschrieben. Warum das genau für die Fälle so entschieden wurde, kann ich Ihnen nicht sagen.
                  Zitat von ITMedia Beitrag anzeigen
                  Ich benötige das für ein PHP-Script das bisher auf der alten 32-er Plattform nicht lief weil Datenbank auf der 32er bei PHP 7.2 nur MariaDB 10.1 / MySQL 5.0 - somit die Webserver (Cient-Version) einfach nur alt war.

                  Als Client benötige ich aber neuere Versionen ab: : libmysql - mysqlnd 7.4.27 bei einer Admin Version von mind. 5.1.1
                  Ich habe das entsprechend nachgefragt und werden Ihnen antworten sobald Infos dazu vorliegen.

                  Mit freundlichen Grüßen

                  Nils Dornblut
                  Blog - Facebook - Twitter
                  Communitybetreiber: domainfactory GmbH
                  Impressum / Pflichtangaben

                  Kommentar


                    #9
                    Zitat von ITMedia Beitrag anzeigen
                    Mir fehlen also aussagen zur:
                    Webserver bzw. Datenbank-Client Version.

                    Kann mir vielleicht jemand von euch sagen wo ich diese Infos finde oder welche Datenbank-Client Version nun aktuell ist?
                    Die mysqlnd Version können Sie in der phpinfo() einsehen.

                    Beispiel für PHP 8.0.12:
                    Klicken Sie bitte auf die Grafik für eine vergrößerte Ansicht

Name: 2022-02-28_23h50_37.png
Ansichten: 84
Größe: 86,8 KB
ID: 11028

                    Bei 7.2 ist die älter:

                    mysqlnd 5.0.12-dev - 20150407

                    bei 7.3 auch

                    mysqlnd 5.0.12-dev - 20150407

                    bei 7.4

                    mysqlnd 7.4.25

                    bei 8.0

                    mysqlnd 8.0.12

                    bei 8.1

                    mysqlnd 8.1.0

                    Das entspricht immer der entsprechenden Version im PHP-src:

                    https://github.com/php/php-src/blob/...qlnd/mysqlnd.h

                    Mit freundlichen Grüßen

                    Nils Dornblut
                    Blog - Facebook - Twitter
                    Communitybetreiber: domainfactory GmbH
                    Impressum / Pflichtangaben

                    Kommentar

                    Lädt...
                    X