Ankündigung

Einklappen
Keine Ankündigung bisher.

Installation von ownCloud / Nextcloud

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Daniel
    antwortet
    Zitat von tju79 Beitrag anzeigen
    Hier ist der angekündigte Link dazu:

    https://www.itfoo.de/web/nextcloud-h...bleme-beheben/
    Hat ein wenig gedauert, bis ich mich wieder damit beschäftigen konnte. Aber genau dieser Link hat mein Problem gelöst!!!
    @tju79: VIelen Dank!!!!

    Einen Kommentar schreiben:


  • tju79
    antwortet
    Hier ist der angekündigte Link dazu:

    https://www.itfoo.de/web/nextcloud-h...bleme-beheben/

    Einen Kommentar schreiben:


  • Daniel
    antwortet
    Hallo zusammen,

    danke für die Hinweise.

    Das Problem mit der htaccess ist gelöst, hab ein Zeichen zuviel gelöscht, daher ging das schief....

    Den Tip mit der php,ini werde ich mal umsetzen, danke für den Tip ;-)

    VG Daniel

    Einen Kommentar schreiben:


  • tju79
    antwortet
    Zitat von masterframe Beitrag anzeigen
    Du hast bei dF tatsächlich keinen Zugriff auf das TEMP Verzeichnis und das ist auch gut so.
    Du kannst aber mit dem PHP INI Editor eine eigene php.ini für die Domain anlegen und somit ein eigenes TEMP Verzeichnis definieren. Dieses liegt idealerweise außerhalb des Webroots der Domain aber innerhalb der Quota. Dann hast du vollen Zugriff auf das TEMP Verzeichnis.
    Genau darum ging es im Artikel. Entweder mit PHP.ini oder mit der config von der Nextcloud. Wenn das fehlt, entstehen die Logouts stand im dem Artikel. Ich kämpfe noch immer damit

    Einen Kommentar schreiben:


  • masterframe
    antwortet
    Du hast bei dF tatsächlich keinen Zugriff auf das TEMP Verzeichnis und das ist auch gut so.
    Du kannst aber mit dem PHP INI Editor eine eigene php.ini für die Domain anlegen und somit ein eigenes TEMP Verzeichnis definieren. Dieses liegt idealerweise außerhalb des Webroots der Domain aber innerhalb der Quota. Dann hast du vollen Zugriff auf das TEMP Verzeichnis.

    Einen Kommentar schreiben:


  • tju79
    antwortet
    Zitat von Daniel Beitrag anzeigen
    Hallo Jan,

    ich habe die o.g. Zeilen in die htaccess eingetragen, danach ging nichts mehr. Dann habe ich die "alte" genommen, damit kann ich wenigstens wieder reinkommen.
    Aber leider erhalte ich regelmäßig die Meldung, dass die Seite nach 5 Sekunden neugeladen wird und dann bin ich wieder auf der Anmeldeseite.....
    Oder aber das passiert direkt ohne weitere Meldung.

    Kann ich das über die htaccess regeln? Oder was muss ich noch an der Cloud einstellen, damit ich nicht immer rausfliege?

    VG Daniel
    Auf einer anderen Seite habe ich den Hinweis entdeckt (gerade auf DF), dass das wohl mit fehlenden temporären Verzeichnissen bzw. nicht definierten Verzeichnissen in der Config zu tun haben soll. Wenn ich die Seite wieder finden sollte, schicke ich den Link.

    Grüße
    Thomas
    Zuletzt geändert von tju79; 22.11.2019, 10:10.

    Einen Kommentar schreiben:


  • Enigma
    antwortet
    Zitat von Daniel Beitrag anzeigen
    ich habe die o.g. Zeilen in die htaccess eingetragen, danach ging nichts mehr. Dann habe ich die "alte" genommen, damit kann ich wenigstens wieder reinkommen.
    Zum Testen müsstest Du sie dann einzeln wieder hinzufügen und schauen, wo es klemmt. Die Strict-Transport-Security-Zeile wie gesagt nur, wenn Du ein SSL-Zertifikat hast.

    Zitat von Daniel Beitrag anzeigen
    Aber leider erhalte ich regelmäßig die Meldung, dass die Seite nach 5 Sekunden neugeladen wird und dann bin ich wieder auf der Anmeldeseite.....
    Oder aber das passiert direkt ohne weitere Meldung.

    Kann ich das über die htaccess regeln? Oder was muss ich noch an der Cloud einstellen, damit ich nicht immer rausfliege?
    Wenn eine Meldung des Skripts erscheint, die das Neuladen der Seite ankündigt, dürfte das nichts mit der .htaccess zu tun haben.

    Gruß
    Jan

    Einen Kommentar schreiben:


  • Daniel
    antwortet
    Hallo Jan,

    ich habe die o.g. Zeilen in die htaccess eingetragen, danach ging nichts mehr. Dann habe ich die "alte" genommen, damit kann ich wenigstens wieder reinkommen.
    Aber leider erhalte ich regelmäßig die Meldung, dass die Seite nach 5 Sekunden neugeladen wird und dann bin ich wieder auf der Anmeldeseite.....
    Oder aber das passiert direkt ohne weitere Meldung.

    Kann ich das über die htaccess regeln? Oder was muss ich noch an der Cloud einstellen, damit ich nicht immer rausfliege?

    VG Daniel

    Einen Kommentar schreiben:


  • Enigma
    antwortet
    Zitat von Daniel Beitrag anzeigen
    Den Tip mit dem temp-Verzeichnis habe ich umgesetzt, aber die htaccess klappt nicht....
    Wenn ich die Änderung wie beschrieben aufnehme, kann ich die Anmeldeseite garnicht mehr laden.
    Gibt es eine Fehlermeldung? Oder bleibt die Seite weiß? Bitte immer so viele Informationen wie möglich geben.

    Kannst Du sagen, welche der Zeilen das Problem hervorruft/hervorrufen? Du kannst einzelne Zeilen durch eine vorangestellte Raute (#) deaktivieren.

    Ein SSL-Zertifikat hast Du für die (Sub-)Domain, oder? Sonst dürfte die Zeile

    Code:
    Header always add Strict-Transport-Security "max-age=15768000; includeSubDomains; preload"
    Dich vor Probleme stellen.

    Gruß
    Jan

    Einen Kommentar schreiben:


  • Daniel
    antwortet
    Hallo,

    ich versuche auch gerade eine OwnCloud einzurichten.
    Ich habe immer mal wieder das Problem, dass ich aus der Cloud abgemeldet werde....

    Den Tip mit dem temp-Verzeichnis habe ich umgesetzt, aber die htaccess klappt nicht....
    Wenn ich die Änderung wie beschrieben aufnehme, kann ich die Anmeldeseite garnicht mehr laden. Was mache ich da falsch? Bzw. was kann ich machen, damit die Cloud-Nutzung ohne Probleme klappt?

    Viele Grüße
    Daniel

    Einen Kommentar schreiben:


  • Enigma
    antwortet
    Okay, danke fürs Nachschauen!

    Gruß
    Jan

    Einen Kommentar schreiben:


  • Nils Dornblut
    antwortet
    Hallo Jan,

    als Grundlage wird auf den Artikel verwiesen (vermutlich für Dich nicht relevant):

    https://www.df.eu/blog/owncloud-installation

    Auch in den Kommentaren unterhalb steht einiges.

    Als Ergänzung wird in einzelnen Threads darauf hingewiesen, dass session.save_path-variable (/tmp) angepasst werden muss auf ein Verzeichnis innerhalb des Webspace. Es kam sonst zu nicht nachvollziehbaren Logouts.

    Man kann wohl auch zusätzlich einen Ordner temp innerhalb des nextcloud Ordners anlegen und in der config.php folgenden Eintrag erstellen:

    'tempdirectory' => '/kunden/<kundennummer_xxx>/webseiten/nextcloud/temp',

    Wenn Dateien bei der Installation fehlen, ist vermutlich mit dem Upload etwas schief gelaufen. Abhilfe schafft sich per SSH sich das Paket laden und zu entpacken.

    In die .htaccess musste ich folgende Zeilen einfügen bzw. abändern:
    Code:
    <IfModule mod_headers.c>
    Header always add Strict-Transport-Security "max-age=15768000; includeSubDomains; preload"
    <IfModule mod_env.c>
    # Add security and privacy related headers
    Header always set X-Content-Type-Options "nosniff"
    Header always set X-XSS-Protection "1; mode=block"
    Header always set X-Robots-Tag "none"
    Header always set X-Download-Options "noopen"
    Header always set X-Permitted-Cross-Domain-Policies "none"
    SetEnv modHeadersAvailable true
    </IfModule>
    </IfModule>
    Ansonsten ist mir nichts neueres da aufgefallen. Wenn du mir noch Stichworte nennst, schaue ich gerne noch einmal.

    Viele Grüße

    Nils

    Einen Kommentar schreiben:


  • Enigma
    hat ein Thema erstellt Installation von ownCloud / Nextcloud.

    Installation von ownCloud / Nextcloud

    Hallo Nils,

    im alten Forum gab es, wenn ich mich nicht irre, ein paar Tipps zur Installation von ownCloud und Nextcloud auf DF-Servern. Könntest Du mal schauen, ob Du da noch was findest?

    Vielen Dank!

    Viele Grüße
    Jan
Lädt...
X