Ankündigung

Einklappen
Keine Ankündigung bisher.

CSS Dateien werden nicht gefunden

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    CSS Dateien werden nicht gefunden

    Sehr geehrtes DF Team,

    wir wollten unsere Webseite nach einiger Zeit nun "schön" machen. Dazu wollten wir natürlich CSS Dateien nutzen (vorher war es nur eine reine html Seite).
    Es stellte sich allerdings heraus, dass die CSS Dateien nicht gefunden werden. Weder von den html Seiten noch wenn man den Link explizit sucht.
    Das der Name falsch geschrieben oder Ordnerstruckturen vergessen wurden kann mit sehr gr0ßer wahrscheinlichkeit ausgeschlossen werden.
    Die CSS Datei ist auch richtig geschrieben, denn auf meinem persönlichen PC funktioniert alles einwandfrei.

    Mit Hilfe des Filezillas sieht man jedoch das die CSS Datei auf dem Server liegt.

    Kann es sich dabei um eine Sperrung oder ähnliches in der htaccess Datei oder etwas ähnlichem handeln?

    Mit freundlichen Grüßen
    Bagel

    #2
    Wo kann man sich das live angucken?
    Kannst du einen Screenshot von FileZilla hier bereit stellen?

    Es kann sich nur im einen Tippfehler handeln.
    CSS Dateien unterliegen keiner Sperrung.

    Auf den dF Systemen (auf Linux allgemein) wird zwischen GROSS und Kleinbuchstaben unterschieden.

    MfG,
    masterframe

    Kommentar


      #3
      Ggf helfen schon 2 Dinge

      1. eine BaseUrl festlegen:

      <base href ="https://www.domainname.de/"> (natürlich richtige URL einsetzen!)

      2. ein "/" vor den Pfad zu den CSS-Dateien zu setzen

      Theoretisch sollten 1/2 sogar unabhängig voneinander funktionieren
      Markus
      ---
      https://www.facebook.com/markus.weber.180410

      Kommentar


        #4
        Klicken Sie bitte auf die Grafik für eine vergrößerte Ansicht

Name: Fillezilla_ansicht.PNG
Ansichten: 89
Größe: 110,3 KB
ID: 1731

        Das ist die Ansicht im Filezilla
        Die Quellcodes:

        HTML-Code:
          <html lang="de"> <head> <style type="text/css"> </style> <link rel="stylesheet" href='owncss.css' type="text/css" /> </head>  <body> Hallo Welt </body> </html>
        Die CSS Datei:
        Code:
        body {background: blue}
        Aber wie gesagt auf meinem PC funktioniert es ohne Probleme.
        Und bezüglich des Links hab ich schon alles mögliche ausprobiert, also vom Root aus, den expliziten Link, ein Ordner zurück und so weiter.

        Kommentar


          #5
          Was mir gerade noch einfällt

          Wir haben den Webspace nicht direkt von DF sondern von einem Drittanbieter, der allerdings bei DF hostet.
          Der Drittanbieter hat aber scheinbar keine Ahnung von Servern und bei anderen Kunden funktioniert es ohne Probleme.
          Kann dieser Anbieter vielleicht was falsch gemacht/geändert haben?

          Kommentar


            #6
            Probier mal aus, ob beim Aufruf der Seite im Browser die CSS überhaupt geladen wird (Das HTML ist übrigens in Ordnung).

            Einfach mal im Chrome/FireFox die Taste F12 drücken und dann in den Reiter "Network" gehen. Dort siehst Du ob die CSS geladen wird. Ist dies nicht der Fall dann kann es sein, dass die CSS auf Dateisystemebene einem anderen User gehört und der Webserver sie nicht lesen kann/darf.
            Dann können wir Dir hier beschrieben wie man das fixt
            Markus
            ---
            https://www.facebook.com/markus.weber.180410

            Kommentar


              #7
              Also wenn ich eine Netzwerkanalyse (Firefox) mache erscheint beim css der Status "404 not found".
              Was wohl bedeutet, dass die Datei nicht geladen wurde.
              Über Hilfe wäre ich wirklich dankbar

              Kommentar


                #8
                Zitat von Bagel112358 Beitrag anzeigen
                Was mir gerade noch einfällt

                Wir haben den Webspace nicht direkt von DF sondern von einem Drittanbieter, der allerdings bei DF hostet.
                Der Drittanbieter hat aber scheinbar keine Ahnung von Servern und bei anderen Kunden funktioniert es ohne Probleme.
                Kann dieser Anbieter vielleicht was falsch gemacht/geändert haben?
                Dann möchte ich dem Kollegen nicht in Parade fahren.
                Bitte Ihn sich um das Problem zu kümmern oder hoste direkt bei dF.
                MfG,
                masterframe

                Kommentar


                  #9
                  Zitat von masterframe Beitrag anzeigen
                  Dann möchte ich dem Kollegen nicht in Parade fahren.
                  Bitte Ihn sich um das Problem zu kümmern oder hoste direkt bei dF.
                  Richtig

                  Der Weg wäre übrigens über den Dateimanager unter admin.df.eu (oder im RP2) das Dateirecht richtig zu setzen.....nur falls Dein Hoster da Hilfe benötigt
                  Markus
                  ---
                  https://www.facebook.com/markus.weber.180410

                  Kommentar


                    #10
                    Dann probier ich noch mal über den Hoster.

                    Vielen Dank für die schnelle Hilfe

                    Kommentar

                    Lädt...
                    X