Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem mit Coppermine

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Problem mit Coppermine

    Moin!

    ich habe über das Kundenmenü Coppermine installiert. Die Domain ist auf PHP 7-73Latest-Standard gestellt, die Datenbankversion ist 5.6.19. Das Computermachine sagt beim Seitenaufruf:

    PHP-Code:
    DeprecatedMethods with the same name as their class will not be constructors in a future version of PHPInspekt_Error has a deprecated constructor in /kunden/trgsites.de/fotos/coppermine/include/inspekt/error.php on line 31

    Deprecated
    Methods with the same name as their class will not be constructors in a future version of PHPInspekt_Cage has a deprecated constructor in /kunden/trgsites.de/fotos/coppermine/include/inspekt/cage.php on line 40

    Deprecated
    Methods with the same name as their class will not be constructors in a future version of PHPInspekt_Supercage has a deprecated constructor in /kunden/trgsites.de/fotos/coppermine/include/inspekt/supercage.php on line 42

    Deprecated
    Methods with the same name as their class will not be constructors in a future version of PHPcpg_debugger has a deprecated constructor in /kunden/trgsites.de/fotos/coppermine/include/debugger.inc.php on line 26

    Fatal error
    Uncaught ErrorCall to undefined function mysql_connect() in /kunden/trgsites.de/fotos/coppermine/include/functions.inc.php:183 Stack trace#0 /kunden/trgsites.de/fotos/coppermine/include/init.inc.php(171): cpg_db_connect() #1 /kunden/trgsites.de/fotos/coppermine/index.php(26): require('/kunden/trgsite...') #2 {main} thrown in /kunden/trgsites.de/fotos/coppermine/include/functions.inc.php on line 183 
    Auf eine ältere PHP-Version umzustellen, was hier sehr gut geklappt hat, habe ich versucht, hat nix gebracht.

    Was kann ich da tun?

    Besten Dank und viele Grüße

    Thomas
    Moin! Ich habe zwei Wordpress-Installationen (vom Kundenmenü installiert) am Laufen. Eine funktioniert prima und updatet sich regelmäßig selbst. Die andere updatet sich seit einiger Zeit nicht mehr selbst und ich kann mich nicht einloggen. Beim Versuch einzuloggen, kommt eine Sammlung für mich nicht verständlicher
    Zuletzt geändert von Thomas Roessing; 05.07.2019, 14:22.
    https://www.roessing.org

    #2
    Welche Version wird denn über das Kundenmenü installiert?
    Die mysql_*-Funktionen wurden bei PHP 7 komplett entfernt. Neuer Standard ist mysqli oder PDO.
    leibt dir also ein manuelles Update auf eine neuere Version von Coppermine oder einen Wrapper für die alten Versionen zu schreiben.

    Kommentar


      #3
      Hallo Thomas,

      Zitat von Thomas Roessing Beitrag anzeigen
      ich habe über das Kundenmenü Coppermine installiert. Die Domain ist auf PHP 7-73Latest-Standard gestellt, die Datenbankversion ist 5.6.19. Das Computermachine sagt beim Seitenaufruf:

      Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /kunden/trgsites.de/fotos/coppermine/include/functions.inc.php:183 Stack trace: #0 /kunden/trgsites.de/fotos/coppermine/include/init.inc.php(171): cpg_db_connect() #1 /kunden/trgsites.de/fotos/coppermine/index.php(26): require('/kunden/trgsite...') #2 {main} thrown in /kunden/trgsites.de/fotos/coppermine/include/functions.inc.php on line 183[/PHP]
      Die Coppermine Photo Gallery aus dem Kundenmenü benötigt die PHP-Version 5.3. Da "mysql_connect()" in den neuen PHP-Versionen nicht mehr verwendet wird, kommt es hierbei zum Fehler. Informationen zu "mysql_connect()" können Sie auch HIER entnehmen.
      Zuletzt geändert von Marcel Kaufmann; 05.07.2019, 16:10.
      Blog - Facebook - Twitter
      Communitybetreiber: domainfactory GmbH
      Impressum / Pflichtangaben

      Kommentar


        #4
        Zitat von Lukas M. Beitrag anzeigen
        Welche Version wird denn über das Kundenmenü installiert?
        Moin,

        1.5.46, sagt das Kundenmenü. Das sagt allerdings auch, man brauche PHP 5.3 und das ist meiner Einnerung nach ziemlich doomed.

        Zitat von Lukas M. Beitrag anzeigen
        leibt dir also ein manuelles Update auf eine neuere Version von Coppermine oder einen Wrapper für die alten Versionen zu schreiben.
        Da ich nciht weiß, was ein Wrapper überhaupt ist, versuche ich es dann wohl gelegentlich mal mit einer manuellen Coppermine-Installation, sowas ging ja früher auch ohne Kundenmenü.

        Danke und viele Grüße

        Thomas

        https://www.roessing.org

        Kommentar


          #5
          Gerade nachgeschaut: Auf der Webseite gibt es bereits eine 1.6er Version. Damit müsste es funktionieren.

          Marcel Kaufmann : Magst du da mal eine Aktualisierung anregen?

          Ein Wrapper wäre in dem Fall etwas, was die mysql-Funktionen nachbildet und intern auf mysqli umsetzt.

          Kommentar


            #6
            Zitat von Lukas M. Beitrag anzeigen
            Gerade nachgeschaut: Auf der Webseite gibt es bereits eine 1.6er Version. Damit müsste es funktionieren.

            Marcel Kaufmann : Magst du da mal eine Aktualisierung anregen?
            Gerne! Wurde soeben weitergegeben.

            Blog - Facebook - Twitter
            Communitybetreiber: domainfactory GmbH
            Impressum / Pflichtangaben

            Kommentar


              #7
              Hallo zusammen,

              die Coppermine Photo Gallery steht nun im Kundenmenü im Menüpunkt „Applikationen“ in der Version 1.6.06 zur Verfügung.

              Blog - Facebook - Twitter
              Communitybetreiber: domainfactory GmbH
              Impressum / Pflichtangaben

              Kommentar


                #8
                Zitat von Marcel Kaufmann Beitrag anzeigen
                Hallo zusammen,

                die Coppermine Photo Gallery steht nun im Kundenmenü im Menüpunkt „Applikationen“ in der Version 1.6.06 zur Verfügung.
                Super,

                jetzt hat die Installation glatt funktioniert!

                Viele Grüße

                Thomas
                https://www.roessing.org

                Kommentar

                Lädt...
                X