Ankündigung

Einklappen
Keine Ankündigung bisher.

TLS connect failed

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #16
    Auch mit SMTP treten diese Fehler auf, aber nur bei hotmail.de, hotmail. com und live.de

    Zitat von Nils Dornblut Beitrag anzeigen
    Unsere Webserver im alten Image können nur unverschlüsselt oder über TLS 1.0 verschlüsselt versenden. Wenn also der empfangende Mailserver TLS voraussetzt, aber 1.0 nicht mehr aktiv ist, kommt es zu so einem Fehler. Das ist leider auch ein Problem des alten Images

    Wir empfehlen in solchen Fällen den Versand auf SMTP umzustellen. In den aktuellen 64-Bit-Tarifen tritt der Fehler nicht auf, dort konnten wir entsprechende Aktualisierungen vornehmen.

    Kommentar


      #17
      Zitat von Anton Korduan Beitrag anzeigen
      Entscheidend ist wohl SENDHOST - hier habe ich ssl://sslout.df.eu eingetragen, das müsste doch passen, das ist doch der "df-eigene SMTP-Server", oder?
      Ja, genau! Ich denke du hast diesbezüglich alles richtig eingestellt.

      Zitat von Vielfärber Beitrag anzeigen
      Auch mit SMTP treten diese Fehler auf, aber nur bei hotmail.de, hotmail. com und live.de
      Meinst du, die hier beschriebenen Problem treten auch auf, wenn man ganz "konventionell" per Emailprogramm (statt Webserver-Script) an die genannten Microsoft-Dienste schreibt?

      Kommentar


        #18
        Zitat von jjknw Beitrag anzeigen
        Meinst du, die hier beschriebenen Problem treten auch auf, wenn man ganz "konventionell" per Emailprogramm (statt Webserver-Script) an die genannten Microsoft-Dienste schreibt?
        Nein, ich meinte damit, dass ich Rückmails vom mailerdaemon mit dem TLS-Fehler bekommen habe, die nicht nur an hotmail- oder live-Mailadressen ging.
        Ich habe sogar direkt bei einer Kundin nachgefragt und sie hat bestätigt, dass sie nichts mit hotmail zu tun hat.

        Aber wie gesagt - ich muss jetzt erstmal mein Script genauer ansehen. Denn es betrifft nur eine bestimmt Art von e-Mails (Kursanmelde-Bestätigungen für Trainer). Alle anderen Mails werden erfolgreich ausgeliefert...

        Kommentar


          #19
          Test läuft ... erwarte die Tage eine Rückmeldung von einer Kursleiterin. Gebe Euch dann hier Bescheid.

          Kommentar


            #20
            Mit ssl://sslout.df.eu klappt es

            Kommentar


              #21
              Ich habe das gleiche Problem jetzt bei einem Kunden mit Joomla-Webseite, wo über die Erweiterung Acymailing Newsletter versendet werden.
              Es sind Mailfehler von einem Mailversand zurückgekommen, der bereits einige Tage alt ist, wobei die Empfänger keine hotmails etc. Adressen sind, sondern großteils normale Mailpostfächer mit Domainnamen z.B. [email protected] usw.
              Die Mails wurden offenbar über den phpmailer versendet, ich habe das jetzt direkt in Acymailing auf SMTP umgestellt mit entsprechender Mailadresse vom Kunden (sslout.df.eu usw.) - wird das Problem damit behoben sein?

              Wir versenden die Newsletter schon seit Jahren so und hatten bislang noch nie ein Problem, die Empfänger wechseln nur leicht, die meisten sind gleichbleibend.

              Fehler im Detail:
              TLS connect failed: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version; connected to 85.158.181.26.
              I'm not going to try again; this message has been in the queue too long.

              Kommentar


                #22
                Zitat von zero81 Beitrag anzeigen
                Es sind Mailfehler von einem Mailversand zurückgekommen, der bereits einige Tage alt ist,
                Dass der Mailfehler erst nach ein paar Tagen auftritt (bzw. vom MailerDaemon gemeldet wird) liegt daran, dass die zu versendenden Nachrichten in der Warteschleiffe waren. Nach ein paar vergeblichen Versuchen, die Nachrichten zuzustellen wird erst die Fehlermeldung abgesetzt.

                ~~~

                Ich bin übrigens kurz davor die Fehlerursache (für meinen Fall) herauszufinden.
                Warte noch auf die Bestätigung meiner Kunden, sieht aber schon sehr gut aus.

                Melde mich, sobald ich es offiziell bestätigen kann.

                Kommentar


                  #23
                  Danke, hab mir schon gedacht, dass die Mails in einer Schleife waren, allerdings hatte ich das noch nicht, dass der Fehler so spät kommt.

                  Bin gespannt. Wie gesagt, ich habe jetzt mal auf SMTP umgestellt, das war davor nur in der Joomla-Konfiguration eingestellt, aber das Acymailing hat dafür eine eigene Einstellung, wie ich jetzt gesehen habe.

                  Kommentar


                    #24
                    Hallo Herr Korduan, hallo zusammen,

                    ich antworte mal vom ältesten zum jüngsten Post. Ich weiß, es kam noch einiges nach. Ich will aber nicht, dass etwas hinten rüber fällt.

                    Zitat von Anton Korduan Beitrag anzeigen
                    Was bedeutet das "alte Image"?
                    Ist das scheinbar der Server, auf dem mein Hosting-Paket läuft?
                    Richtig, bis zu allen Tarifen die ein "64" im Namen haben und originär durch uns bereitgestellt werden, also keine Konzernprodukte sind, laufen die Webserver (egal ob Shared oder Managed Hosting) mit dem von mir als alten Image bezeichneten Grundsystem. Das ist im Prinzip das Betriebssystem und alle Anwendungen wie Webserver, Skriptsprachen usw.

                    Zitat von Anton Korduan Beitrag anzeigen
                    Ich kann diese Fälle leider nicht so einfach unterscheiden - das hängt ja vom Empfänger ab.

                    Meine SaaS-Anwendung versendet an meine Kunden e-Mails - da müsste ich jetzt ja extra eine Option einprogrammieren, bei welcher der Kunde wählen kann, ob sein Provider TLS 1.0 unterstützt ...
                    Das wäre ein deutlicher zusätzlicher Aufwand - und diesen "Technik-Talk" würde außerdem keiner der Kunden verstehen.
                    Das würde keinen Sinn machen das auf die Weise umzusetzen. Wie später noch diskutiert muss der Versand über unsere anderen SMTP-Mailserver erfolgen. In Ihrem Fall ist es so, dass quasi der Webserver der Mailserver ist und hier grob gesagt recht alte Standards nutzt. Viele bzw. nahezu alle Kunden werden nicht wissen was für eine Basis der empfangende Mailserver hat und was dieser für Verschlüsselung unterstützt. Von daher der Rat zu SMTP.

                    Zitat von Anton Korduan Beitrag anzeigen
                    Bleibt mir also tatsächlich nur die Möglichkeit auf einen 64-Bit-Tarif umzustellen?
                    Ich hatte damals bei der Einführung schon darüber nachgedacht, aber ein paar (für mich) nennenswerte Kontrapunkte gefunden, darum habe ich es bleiben lassen ...
                    Mal abgesehen davon, dass wir das generell für demnächst empfehlen würden, bleibt Ihnen wie gesagt die Umstellung auf SMTP. Aber ja, der Tarifwechsel würde es lösen. LAssen Sie uns ggf. aber dann noch die Themen diskutieren, die Sie am Wechsel aktuell hindern.
                    Zitat von Anton Korduan Beitrag anzeigen
                    Nachtrag2: Denken Sie, dass das TLS1.0-Problem bei Hotmail vielleicht etwas ist, das sich mit der Zeit von selbst erledigen wird, weil es veraltet und ausgemustert wird? Es scheinen übrigens auch andere Provider betroffen, nicht nur hotmail.
                    Nein, das wird sich nicht lösen, da es eigentlich gut ist, wenn die Provider sich in die Richtung mehr Sicherheit bewegen. Das Problem ist tatsächlich unser in dem Punkt nicht mehr aktualisierbares altes Image.

                    Zitat von Anton Korduan Beitrag anzeigen
                    Nachtrag3: Sorry für die vielen Nachträge, aber das Thema ist brisant für mich. Ich habe in meinem Script nachgesehen (verwende PHP-Mailer) und dort ist bei der Angabe SMTPSecure angegeben "static::ENCRYPTION_SMTPS". Sieht so aus, als würde ich bereits per SMTP versenden, oder?
                    Na ja, das sagt erst einmal nichts direkt. Nur wenn Sie einen E-Mail Account mit Adresse und Passwort irgendwo im Skript angegeben haben, besteht die Chance, dass der Versand per SMTP funktioniert.

                    Mit freundlichen Grüßen

                    Nils Dornblut

                    Blog - Facebook - Twitter
                    Communitybetreiber: domainfactory GmbH
                    Impressum / Pflichtangaben

                    Kommentar


                      #25
                      Zitat von jjknw Beitrag anzeigen
                      Ich glaube, Nils Dornblut befürchtet, dass dein Script (welches auf dem Webserver läuft) direkt mit den SMTP-Servern deiner Empfänger kommuniziert. Da sieht er das Problem.
                      Nicht ganz, unser Webserver mit den alten Ciphern und TLS 1.0/1.1 kommuniziert mit Mailservern (in dem Fall bei Hotmail), die das nicht mehr unterstützen

                      Zitat von jjknw Beitrag anzeigen
                      Als er schrieb

                      meinte er wohl, dass du dein Script (PHP-Mailer) so umstellen solltest, dass es nicht direkt mit den SMTP-Server der Empfänger sprechen sollte, sondern ausschließlich mit den für den Email-Versand vorgesehenen dF-eigenen SMTP-Servern. Diese kümmern sich in weiterer Folge darum, deine Mails "ordnungsgemäß" an die Empfänger weiterzureichen. Hierbei sollte auch das TLS-Thema kein Problem mehr darstellen ...
                      Genau!

                      Mit freundlichen Grüßen

                      Nils Dornblut
                      Blog - Facebook - Twitter
                      Communitybetreiber: domainfactory GmbH
                      Impressum / Pflichtangaben

                      Kommentar


                        #26
                        Zitat von Anton Korduan Beitrag anzeigen
                        Wie funktioniert das, was Du beschreibst - also ausschließlich mit den "df-eigenen SMTP-Servern" zu kommunizieren?
                        Das müste ich doch in der e-Mail-Config einstellen, richtig?

                        Diese sieht beispielshaft so aus:

                        mail->IsSMTP(); // tell the class to use SMTP
                        $mail->Host = SENDHOST; // SMTP server
                        $mail->SMTPAuth = true; // enable SMTP authentication
                        $mail->Username = SENDUSERNAME; // SMTP server username
                        $mail->Password = SENDPASSWORD; // SMTP server password
                        $mail->SMTPSecure = SENDSECURE;
                        $mail->Port = SENDPORT; // set the SMTP server port


                        Entscheidend ist wohl SENDHOST - hier habe ich ssl://sslout.df.eu eingetragen, das müsste doch passen, das ist doch der "df-eigene SMTP-Server", oder?
                        Wenn dort mit SENDUSERNAME an SENDPASSWORD ein E-Mail-Account den Sie im Kundenmenü eingerichtet haben angesprochen wird und die Variablen entsprechend befüllt sind mit der E-Mail-Adresse und dem Passwort des E-Mail-Accounts, dann sollte das klappen mit dem SENDHOST.

                        Die Frage ist, was war denn da vorher drin? Weil dann würden Sie wirklich per SMTP schon versenden bzw. das probieren, aber Hotmail stört sich an dem Versand vermutlich dann weil vermutlich smtp.domain.tld drin war, welche natürlich kein Zertifikat hat. Aber mal sehr ins Unreine gesprochen...

                        Mit freundlichen Grüßen

                        Nils Dornblut
                        Blog - Facebook - Twitter
                        Communitybetreiber: domainfactory GmbH
                        Impressum / Pflichtangaben

                        Kommentar


                          #27
                          Zitat von Vielfärber Beitrag anzeigen
                          Auch mit SMTP treten diese Fehler auf, aber nur bei hotmail.de, hotmail. com und live.de
                          Okay, aber wie erfolgt der Versand bzw. könnte meine Theorie stimmen im Posting vorab?

                          Mit freundlichen Grüßen

                          Nils Dornblut
                          Blog - Facebook - Twitter
                          Communitybetreiber: domainfactory GmbH
                          Impressum / Pflichtangaben

                          Kommentar


                            #28
                            Zitat von zero81 Beitrag anzeigen
                            Ich habe das gleiche Problem jetzt bei einem Kunden mit Joomla-Webseite, wo über die Erweiterung Acymailing Newsletter versendet werden.
                            Es sind Mailfehler von einem Mailversand zurückgekommen, der bereits einige Tage alt ist, wobei die Empfänger keine hotmails etc. Adressen sind, sondern großteils normale Mailpostfächer mit Domainnamen z.B. [email protected] usw.
                            Die Mails wurden offenbar über den phpmailer versendet, ich habe das jetzt direkt in Acymailing auf SMTP umgestellt mit entsprechender Mailadresse vom Kunden (sslout.df.eu usw.) - wird das Problem damit behoben sein?

                            Wir versenden die Newsletter schon seit Jahren so und hatten bislang noch nie ein Problem, die Empfänger wechseln nur leicht, die meisten sind gleichbleibend.

                            Fehler im Detail:
                            TLS connect failed: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version; connected to 85.158.181.26.
                            I'm not going to try again; this message has been in the queue too long.
                            Die Frage auch hier ist, wie versendet das Skript die E-Mails? Über den Webserver (früher sagte man via sendmail) oder per SMTP. Wenn letztgenanntes mit richtiger Konfiguration genutzt wird, sollte es klappen ohne Meldungen.

                            Mit freundlichen Grüßen

                            Nils Dornblut
                            Blog - Facebook - Twitter
                            Communitybetreiber: domainfactory GmbH
                            Impressum / Pflichtangaben

                            Kommentar


                              #29
                              Zitat von Nils Dornblut Beitrag anzeigen

                              Die Frage auch hier ist, wie versendet das Skript die E-Mails? Über den Webserver (früher sagte man via sendmail) oder per SMTP. Wenn letztgenanntes mit richtiger Konfiguration genutzt wird, sollte es klappen ohne Meldungen.

                              Mit freundlichen Grüßen

                              Nils Dornblut
                              Wie es scheint, erfolgte der Versand über den phpmailer von Joomla, da ich dachte, die Umstellung in der Joomla Konfiguration auf SMTP (inkl. der benötigten Daten zum Postfach) bedeutet, dass alles über SMTP versendet wird. Gestern ist mir erst aufgefallen, dass das Acymailing-Plugin (Newsletter Erweiterung) eine eigene Einstellung dafür hat, diese habe ich jetzt auch auf SMTP umgestellt bzw. eingerichtet, zwei Testmails an mich waren problemlos. Hier müssen wir wahrscheinlich den nächsten Newsletter abwarten und ev. einige der betroffenen Empfänger nach dem Mailerhalt fragen.

                              Kommentar


                                #30
                                Zitat von zero81 Beitrag anzeigen

                                Wie es scheint, erfolgte der Versand über den phpmailer von Joomla, da ich dachte, die Umstellung in der Joomla Konfiguration auf SMTP (inkl. der benötigten Daten zum Postfach) bedeutet, dass alles über SMTP versendet wird. Gestern ist mir erst aufgefallen, dass das Acymailing-Plugin (Newsletter Erweiterung) eine eigene Einstellung dafür hat, diese habe ich jetzt auch auf SMTP umgestellt bzw. eingerichtet, zwei Testmails an mich waren problemlos. Hier müssen wir wahrscheinlich den nächsten Newsletter abwarten und ev. einige der betroffenen Empfänger nach dem Mailerhalt fragen.
                                Ja, guter Punkt. Nicht alle Plugins nutzen da jeweils die zentralen Einstellungen. Das mag auch jeweils bei anderen Skripten so sein und nehme ich in meine Nachfrageliste bei ähnlichen Problemen mal mit auf. Danke für den Hinweis.

                                Mit freundlichen Grüßen

                                Nils Dornblut
                                Blog - Facebook - Twitter
                                Communitybetreiber: domainfactory GmbH
                                Impressum / Pflichtangaben

                                Kommentar

                                Lädt...
                                X